A Makerbot disaster struck!

I’m not sure what’s been going on with my makerbot, but I don’t like the way it has been progressing! All week long I have been having trouble with my extruder board. I’ve been talking with Matt at Makerbot and he has been super helpful, but we haven’t figured it out yet. It will give me the dreaded “toolhead 0 : not found” error, and once finally connected it will “get tired” mid print and stop heating.

Well… today it stopped heating the extruder tip while printing, then it snagged on the print, bent the brass tube, and the hot end snapped off of the mount with a little flourish!

broken makerbot hot end

I’m going to try to find the drawings for the plastic mount piece that broke. Thankfully that ought to be easy enough to make by hand. After that I have to say I’m at a loss as for what I can do to prevent this from happening again. This is why they call it DIY. I just wish sometimes it was more “doing”, and less “yourself”.

$10 DIY Makerbot filament spool

I can’t believe it took this long, but I finally had a bad filament tangle last week, and a few aborted prints because my old setup wasn’t working. I really needed to get my filament spooled so that it would nicely dispense, and not jam, tangle, or unspool.

I really love the way the official makerbot kit looks, and I bet it really works smoothly. I just don’t have $90 sitting around. I’ve already spent that on ABS, relays, arduinos, and prusa parts!

I went down to the old Home Depot and picked up a cheap ($8) extension cord spool and a few feet of nylon water tubing. My extruder hasn’t had any trouble with its grip, so this creation has the extruder just pull the filament off the spool. I drilled out the handle and carefully spooled the ABS on the spool. THAT took a while, but it’s way better than having to constantly babysit the machine.


Continue reading

Makerbot extruder fixed!

It all came down to this…

When I assembled the extruder (makerbot mk4) the allen wrench that came with the kit never felt right. Regardless I tightened the set screws on the gear until the allen wrench felt like it was about to strip it, and then I went on my merry way. After watching my extruder not work for the last few weeks I finally:
1) rebuilt my hot end
2) put longer leads on the thermistor and nichrome so I could move the extruder board out of the way
3) put a light on my table next to the maker bot, and
4) noticed that the motor shaft was spinning but the gear was not!

So I disassembled the extruder, found the RIGHT sized allen wrench (1.5mm maybe?) tightened everything down, and I was on my way! It’s frustrating that it took so long to figure it out, but I’m so glad that I finally did. I spent the morning printing out an accessible wade’s extruder and playing around in skeinforge.

I wasn’t able to print out the small gear on the wades extruder no matter what I tried. It always ended up getting eaten by blob monsters. I eventually figured out how to use the multiply feature in skeinforge and printed out 9 of them. With no raft to boot! The no raft thing was only cool because I figured out how to do it, but in the end three or four of them broke free and were garbage.

That last pic is what I was really surprised with. I have never printed without a raft before, and I was really happy with how flat and smooth the surface was. One more thing pushing me towards building that heated bed!

DIY heated build platform for makerbot cupcake.

Let’s give this a try!
Tonight I prepped 4 3ohm 10 watt aluminum resistors with in two parallel pairs with solid copper wire. I gave it 12 volts of juice and it got plenty hot quickly, so hopefully this back of the matchbook effort will pay off.

I don’t have the aluminum plate with me, so I only prepped the electronics. This is what they look like.

And here is a closeup of one resistor.

I have been reading a few other blogs about other peoples diy hbp builds and I was getting really confused. Hydraraptor is using 9(!) 48ohm resistors on his reprap hbp. That seemed really high, considering the people doing it with nichrome wire only have about 6 ohms total.

Then I realized that Hydraraptor is using 240VAC. That seems dangerous, and in one of his posts he mentions how one of his resistors failed and ended up melting a bunch of his circuit breakers. Yikes, that’s not for me.

My plan is to set this up on an aluminum plate with the stock thermistor from the makerbot kit. I’m still unable to print because of some extruder issues, but this is a good distraction while I try to figure that out. I’m also going to try building one with nichrome wire. IF it works as well then it’ll be lower profile than this resistor configuration.

What to do with a broken makerbot?


As I’ve been blogging, my makerbot is sick (as in broken).

Yesterday as a fun distraction I ran across the makerbot music page. Thankfully you don’t need an extruder in order to make music, so I dropped the lady Gaga “bad romance” gcode onto my bot and hit run. It was a good break, and it was great to feel like my makerbot is actually capable of doing something for a change. While it isn’t as cool as printing something out of plastic, it’s a much faster way to confuse and amaze your friends!

assembling a metrix createspace molded wades extruder

I recently bought a molded reprap prusa mendel kit from Metrix create space. They are a hacker space in Seattle, Wa. The molded kits cost anywhere from a third to half of what a set of printed parts cost because they take far less time to produce. One downside of the printing method is that parts will end up sloppier and require some more post processing.

Here is what the base looked like as it arrived.

Here is the other three parts, unprocessed.

The next picture is where you can start to see the disadvantages of this method. There is a lot of plastic on the bearing holder (purple) that needs to be cut away, and you can see the way that the miniscus on the big gear has made the entire gear cupped. I want to clearly state: none of those are deal breakers. This is a great deal, and even the RP parts require a fair bit of processing. I was surprised when these parts came in, but after thinking about it I don’t think I should be. They appear to be functional, and that’s all that really matters to me. As long as they last long enough to print their replacements, I’ll be happy!

Hit the jump for how to build it!

Makerbot down! We have a makerbot down!

I’ve only had the makerbot for a month now, but it’s refusing to print. Sigh. I know it’s a diy kit, but this little puppy only had three whistles printed on it before it rolled over, ready to die. Here is my thought process as I go about trying to fix it.

Symptoms: The extruder would no longer extrude. RepG registers 220 and the hot end seems to settle nicely there. The motor turns on but nothing comes out. I have a mk4 extruder and was in the process of printing a wade’s extruder when the symptoms started (do you think it got jealous?) If I grabbed the filament with pliers then I could push plastic out the tip, but it also squeezed out between the pfte insulator and the brass barrel.

My Diagnosis: After adjusting and re-adjusting the difficult pressure wheel on the mk4 I settled on the idea that the tip must be partially blocked or not hot enough. I took it apart and broke the brass barrel in two. Then I made a new barrel out of a bolt and bought a new barrel (two path approach!)


Here you can see that the nichrome wire has burned/melted the kapton tape. Is that normal?

Results:
None good. The stock barrel behaved exactly the same. It would flow, but weakly and only with considerable pushing on my end. The new hot end I made fared about as poorly. I tried to re-use the nichrome wire from the original hot end build, but at some point it had burned off its coating and this was very problematic.

Next steps:
1 – rebuild stock barrel/ptfe combo
2 – test resistance of nichrome on new barrel
3 – buy and build wades extruder
4 – use both extruders on mk4 setup to see if it is the hot end, then swap in the wades extruder to see if it is the motor.

Designing gears, cogs, sprockets in illustrator for laser cutting

I really enjoy building mechanical movements, and I am terrible at it. It is really difficult to build things that move without relying on expensive pre-built mechanisms. Thus I am always looking for cheap ways to design and build cogs, gears, and sprockets.

For gears it is tough to beat the online wooden gear generator at woodgears.ca. It lets you specify size and number of gears, and also lets you see how they mesh and tweak a bunch of variables. I usually print these to pdf and then import them as vector to illustrator. With this site you can build any number of compatible gears. They have rather large teeth because they are meant to be cut out of wood with a bandsaw, but they will work very well for low-precision work. There is also an inkscape plugin that generates gears as described here by MAKE.

One note on importing all of these files into illustrator. Illustrator has strange import prefs, and if you import a dxf that is in mm, and your preferences are in inches, centimeters, or anything else, then it will scale your drawing on import. Be careful. This is an easy way to mess up at the very first step.

Timing belt cogs are another deal entirely. There isn’t an online generator. There are a few python scripts that purport to build cogs, but they never seem to work right. One other way to do it is with blender and a plugin, but then you end up doing more 3d modeling than cutting.

To build one in illustrator you will need to know the belt you plan on using and the number of teeth you want the cog to have. You will also want to go to sdp-si and download an example any cog that uses your belt pitch. Set your units to mm in illustrator>preferences>units. Grab the dxf of that cog and open it up in illustrator.

More than likely you will see something similar to the image below. It has two example teeth showing the tooth spacing, but the entire cog isn’t drawn out as a time saving measure.




here’s how to duplicate out the rest of the teeth and more.

Drilling out a bolt – the hard way

After breaking my makerbot extruder head I decided I wanted to try my hand at making one from scratch. It’s a brass m6 tube with a nozzle screwed onto one end. How hard can it be!

It turns out it’s really hard, but I ended up having luck with a technique called the “afghan lathe”

Before I get too far into it I need to explain that most bolts are made of hardened steel. To de-hardened them all you need to do is to get them red hot with a blowtorch and let them cool slowly. Here is a pic of me doing just that to two m6 bolts.


After your bolt has cooled, it should look something like this.

Start out with a drill press, a vice, some c clamps and a drill bit. Put the drill bit lightly into the drill chuck backwards. Lower the drill press until you can grip the drill bit in the vice (which should be sitting on the drill press table) Clamp the bit in the vice, and the vice to the table VERY securely. Release the chuck on the drill press. Now you are going to take the bolt that you de-tempered and put it in the chuck. I left the head poking out. That will make it easier to get a good straight grip on it. Tighten everything down and grab some machining oil.
Continue reading

Announcing a new habit – Makerbot!

Due to a long and strange twisting string of circumstances I recently ended up with a makerbot kit at work. I have a build video and a lot of info, but here is the first of two quick posts about my trials and tribulations with this little guy. This is more a question to the world, as I am having a terrible time finding answers for it.

I built the bot and printed a whistle within a few hours. Everything seemed copacetic. A few weeks went by (in which I got to go to nyc resistor and meet Bre) and I came back to the bot to print something. It was just not working right. It would extrude for a little bit and then stop, and I could force it to restart and then it would stop again. I’m not sure if the extruder was bad, or the tip was blocked, or the software was just messing up. I took apart the hot end to check for blockages, but I didn’t heat it up fully before disassembly.


Well, this happened. I had two wrenches, one on the shaft and one on the extruder tip. I was trying to unscrew the tip after drilling the plastic partially out of the barrel. And then the brass tore in two. I eventually hit it with a very hot hot air gun (not a hair dryer) and got the plastic to melt out and then I was able to unscrew it easily. So the moral of the story is to always clean out the tube before attempting to unscrew a hot end.

Then I ordered parts from makerbot, assembled the parts when they came in, and still had the same problem! My bot will print out the beginning of a raft if it is warmed up enough, but then it stops extruding and just wiggles around for a long time, not printing anything.

In possibly related news, both versions of the extruder have seeped plastic from above the fender washer. See a picture below. You can see a plastic piece that looks a bit like a leaf coming out of the left side of the washer. In my mind this means that my motor is pushing the filament according to plan and the tip must be blocked.

I just can’t see any reason why my brand new tip would be blocked when I could see light through it!

Well, I’ll put the answer here when I find it. I have a wade’s extruder and a new hot end on its way. Possibly those will fix it. Possibly not. I will also have an upcoming post on making a new hot end, and the Makerbot Cupcake making of video.